• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Moving CI website to another server - only blank page showing

#11
(06-30-2018, 12:33 PM)Leo Wrote:
(06-30-2018, 01:38 AM)skindci Wrote: Tha domain has changed.
The /application/logs/ folder is empty, only an index.html is there... I don't know, why?

Have you checked $config['log_threshold'] in your config.php?
or the log_path and is the log_folder able to be written to?
is environment set to development?

Thanks! The log_threshold was set to 0, I set it to 4. And I gave write permission to the log folder.
I got this log, when I try to load the page:

ERROR - 2018-07-02 12:21:10 --> Severity: Notice  --> Only variable references should be returned by reference /var/www/html/szig/ci/core/Common.php 257
DEBUG - 2018-07-02 12:21:10 --> Config Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Hooks Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Utf8 Class Initialized
DEBUG - 2018-07-02 12:21:10 --> UTF-8 Support Enabled
DEBUG - 2018-07-02 12:21:10 --> URI Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Router Class Initialized
DEBUG - 2018-07-02 12:21:10 --> No URI present. Default controller set.
DEBUG - 2018-07-02 12:21:10 --> Output Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Security Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Input Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Global POST and COOKIE data sanitized
DEBUG - 2018-07-02 12:21:10 --> Language Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Loader Class Initialized
DEBUG - 2018-07-02 12:21:10 --> Config file loaded: /var/www/html/szig/application/config/SZIG_ver.php
DEBUG - 2018-07-02 12:21:10 --> Helper loaded: url_helper
DEBUG - 2018-07-02 12:21:10 --> Helper loaded: szig_helper
DEBUG - 2018-07-02 12:21:10 --> Database Driver Class Initialized
Reply

#12
In the 257. line of the Common.php:
return $_config[0] =& $config;
Reply

#13
I found a possible solution for this error:
https://stackoverflow.com/questions/2834...odeigniter
So I modified the Common.php to this:

Code:
$_config[0] =& $config;
return $_config[0];

But... nothing happened. :/ In Firefox, only a blank page showing, and in Chromium, I got a HTTP error 500.
Reply

#14
Do NOT edit common.php! Put it back the way it was.
Reply

#15
(07-02-2018, 03:37 AM)skindci Wrote:
(06-30-2018, 07:10 AM)dave friend Wrote: How did you place the files and folders of CodeIgniter relative to the website root (public) folder?

The website root folder is the /var/www/html/, and I put the webpage to the /var/www/html/szig/ folder.

Please describe the contents (files and folders) in /var/www/html/szig/

Is index.php in /var/www/html/szig/?

Have you set up a virtual host that sets the DocumentRoot to /var/www/html/szig/?

If you have set up a virtual host what is the ServerName you gave it?
Reply

#16
(07-02-2018, 10:23 AM)dave friend Wrote: Do NOT edit common.php! Put it back the way it was.

Ok, I put it back. Smile
Reply

#17
(07-02-2018, 10:35 AM)dave friend Wrote:
(07-02-2018, 03:37 AM)skindci Wrote:
(06-30-2018, 07:10 AM)dave friend Wrote: How did you place the files and folders of CodeIgniter relative to the website root (public) folder?

The website root folder is the /var/www/html/, and I put the webpage to the /var/www/html/szig/ folder.

Please describe the contents (files and folders) in /var/www/html/szig/

Is index.php in /var/www/html/szig/?

Have you set up a virtual host that sets the DocumentRoot to /var/www/html/szig/?

If you have set up a virtual host what is the ServerName you gave it?

The directory structure:
https://pastebin.com/hJeA8yk5

The directory structure with files:
(this is a big file...) http://tbc_z87.fw.hu/temp/ktfa2.txt


The index.php is in the /var/www/html/szig/public_html folder.
I don't  set virtual host in the apache config.
Reply

#18
New information: I put the error_reporting(E_ALL), and ini_set('display_errors', 1) lines to the index.php. I got some errors:

A PHP Error was encountered
Severity: Notice
Message: Only variable references should be returned by reference
Filename: core/Common.php
Line Number: 257

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/html/szig/ci/database/drivers/mysql/mysql_driver.php:73 Stack trace: #0 /var/www/html/szig/ci/database/DB_driver.php(115): CI_DB_mysql_driver->db_connect() #1 /var/www/html/szig/ci/database/DB.php(148): CI_DB_driver->initialize() #2 /var/www/html/szig/ci/core/Loader.php(346): DB(Array, NULL) #3 /var/www/html/szig/ci/core/Loader.php(1171): CI_Loader->database() #4 /var/www/html/szig/ci/core/Loader.php(152): CI_Loader->_ci_autoloader() #5 /var/www/html/szig/ci/core/Controller.php(51): CI_Loader->initialize() #6 /var/www/html/szig/application/core/SZIG_Controller.php(12): CI_Controller->__construct() #7 /var/www/html/szig/application/controllers/main.php(7): SZIG_Controller->__construct() #8 /var/www/html/szig/ci/core/CodeIgniter.php(308): Main->__construct() #9 /var/www/html/szig/public_html/index.php(251): require_once('/var/www/html/s...') #10 {main} thrown in /var/www/html/szig/ci/database/drivers/mysql/mysql_driver.php on line 73

So... this is a database error, because the programmer used obsolote function?

(Anyway sorry for the stupid questions, I am newbie in CodeIgniter...)
Reply

#19
Do you use the mysql driver in your database.php? see 'dbdriver' => 'mysql',
If yes, don't use that driver use the mysqli driver.
That should be ' dbdriver' => ' mysqli',

André
Reply

#20
I suspect the fatal error is due to your file structure. It's going to be awhile before I can parse it all.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.