• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble getting started

#1
I downloaded CI4, extracted the files and renamed the folder to ci4.

Then i added a virtual host:

Code:

<VirtualHost 127.0.0.1:80>

DocumentRoot "C:\Program Files (x86)\Ampps\www\ci4\public"

ServerName ci4.dev

</VirtualHost>



Quote:

The ci4.dev page isn’t working

ci4.dev is currently unable to handle this request.



Quote:

[Tue Jun 28 07:13:08.222286 2016] [:error] [pid 4596:tid 1300] [client 127.0.0.1:64646] PHP Fatal error:  Uncaught Error: Class 'Config\\App' not found in C:\\Program Files (x86)\\Ampps\\www\\ci4\\public\\index.php:237\nStack trace:\n#0 {main}\n  thrown in C:\\Program Files (x86)\\Ampps\\www\\ci4\\public\\index.php on line 237



I also changed RewriteBase to "/ci4".


PHP version is 7.
Reply

#2
Two things:

1) PHP must be 7.1
2) are you on the master branch or the develop branch? Needs to be develop branch.
Reply

#3
If AMPPS is anything like XAMPP then you should not install it to the windows program files folder.

install it to the root c:\ampps

Also you need to make sure that your windows host file is pointing to localhost 127.0.0.1

c:\windows\system32\drivers\etc\host

edit that file as administrator with notepad and make sure its pointing to localhost.

Also did you start the web server?
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.