• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
C.I Version 3.1.9 x PHP Version Better Compatibility - 06.11.2018

#1
Hello Guys,

According your experience, with which PHP version does C.I 3.1.9 works better please?

5.6.38·Release
7.0.32·Release
7.1.23·Release
7.2.11·Release

I´m trying to run a project developed with PHP 5.6.38 Release in my notebook, but, i use PHP Version 7.1.8 Release installed.

Web Server: Apache 2.4.27 (Win64)

I´m getting error just when i try to call the page through the url. (Page Not Found 404)

According your experience, which PHP Version should i use please? i accept recommendations.

The CodeIgniter User Guide says:

Server Requirements

PHP version 5.6 or newer is recommended.

Is there some conflict when we use PHP Version above Version 7.0 ?

I appreciate all recommendations in advance!

Best regards,
Porto
Reply

#2
@Porto,

I currently use CI with both PHP 5.6 and 7.0.x. My ultimate goal is to get all my projects on PHP 7.1.x espcially with the fact that PHP 5.6 EOF (End Of Life) is Dec 2018. I prefer to usually stay 1 version back.
Reply

#3
(11-06-2018, 09:32 AM)php_rocs Wrote: @Porto,

I currently use CI with both PHP 5.6 and 7.0.x.  My ultimate goal is to get all my projects on PHP 7.1.x espcially with the fact that PHP 5.6 EOF (End Of Life) is Dec 2018.  I prefer to usually stay 1 version back.

Hello @php_rocs,

Thank you so much for your light!

And what should i do to get this project made with PHP 5.6 running on a PHP version 7.1? Locally i use a windows 7 machine.

On Ubuntu Server i think it´s possible to run 2 or 3 different PHP Versions on the same server, but on Windows? Do you use windows platform? Is there some conflict between the PHP Versions working together?

Thank you!
Reply

#4
@Porto,

I use WAMP ( http://www.wampserver.com/en/ ). I have not had any problems porting my code between windows and unix/linux.
Reply

#5
(11-06-2018, 10:57 AM)php_rocs Wrote: @Porto,

I use WAMP ( http://www.wampserver.com/en/ ).  I have not had any problems porting my code between windows and unix/linux.

 @php_rocs,

 Which PHP Version do you use in your Wamp Server?

 This is the actual version to download (06.11.2018).

 Wampserver 3.1.0 64 bit x64

– Apache 2.4.27 – PHP 5.6.31, 7.0.23, 7.1.9 – MySQL 5.7.19 – MariaDB 10.2.8 – PhpMyAdmin 4.7.4 – Adminer 4.3.1 – PhpSysInfo 3.2.7
 
 On Linux do you use the same PHP Version as in your Wamp Server?
Reply

#6
@Porto,

WAMP allows you to jump between versions. I jump between 5.6.x and 7.1.x.

Actually, I haven't upgraded to the newest version yet but that should work just fine.

Yes, I have two projects that are using 5.6.x and 7.1.x. I try my best to keep them very close to each other (they are not exactly the same but very close - the minor version will be off but usually not by much).
Reply

#7
I've been using PHP v7.3 with CI v3.1.9 and it works perfectly. (so far Smile )
Reply

#8
(11-06-2018, 01:37 PM)dave friend Wrote: I've been using PHP v7.3 with CI v3.1.9 and it works perfectly. (so far  Smile  )

This is good to hear @dave_friend! Maybe i´ll be forced to rewrite the pages in the PHP version 7.x
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.