• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
beta 2: filter files missing in composer install

#1
Hi, I just did a new Composer appstarter install and I moved the directories around for a shared system (as usual).

Just running the canned welcome message and I got
ERROR: codeigniter4\framework\system\Filters\DebugToolbar not found

It seems the files: CSRF.php  DebugToolbar.php  and Honeypot.php are missing from the distribution.

====
Update: It seems the initial composer create-project installed alpha 4, but I swear I remember seeing Beta 2 on the running display.
A 'composer update' just now installed Beta 1. weird. I manually moved the beta 2 files over to work around all this.
Reply

#2
Thank you for the heads up - will investigate!
Reply

#3
Hmm - the filters are there in the framework distribution... https://github.com/codeigniter4/framewor...em/Filters
... and the app/Config/Filters.php looks like it is referencing them correctly.

I did the same thing ...
- install (with the "-s beta" option that was missing from the appstarter readme but which has been corrected)
- "php spark serve" and yes, the error you mentioned
- "composer update"
- "php spark serve" and no problems finding the filters
- the welcome page suggests "beta.1" though Sad

Looks like a few hiccups to fix, thanks!
Reply

#4
hmmmmm - the codeigniter4/framework package was still sitting at beta.1 ... it didn't update automatically for some reason.
I have triggered the packagist update, and all seems well now.

A "composer update" inside your app starter should bring all up to beta.2 Smile
Reply

#5
(04-04-2019, 12:43 PM)ciadmin Wrote: hmmmmm - the codeigniter4/framework package was still sitting at beta.1 ... it didn't update automatically for some reason.
I have triggered the packagist update, and all seems well now.

A "composer update" inside your app starter should bring all up to beta.2 Smile

The welcome page displays application and not app:

application/Views/welcome_message.php
Simpler is always better
Reply

#6
(04-04-2019, 07:09 PM)donpwinston Wrote:
(04-04-2019, 12:43 PM)ciadmin Wrote: hmmmmm - the codeigniter4/framework package was still sitting at beta.1 ... it didn't update automatically for some reason.
I have triggered the packagist update, and all seems well now.

A "composer update" inside your app starter should bring all up to beta.2 Smile

The welcome page displays application and not app:

application/Views/welcome_message.php

Doh! Thank goodness for sharp eyes Smile
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.