• 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 4.0.0-rc.1 released

#11
(09-03-2019, 11:23 AM)ciadmin Wrote:
(09-03-2019, 11:19 AM)tgix Wrote: Anyone more knowledgeable in composer that I am may point me in the right direction how to update a beta4 project to rc. Tried changing the require to 4@rc but no go.

Are you talking about the appstarter, framework or devstarter?
The installation method is relevant to your update.

I followed the instructions from the beta4 and seems like I installed the appstarter. My composer.json:
Code:
{
    "name": "codeigniter4/appstarter",
    "type": "project",
    "description": "CodeIgniter4 starter app",
    "homepage": "https://codeigniter.com",
    "license": "MIT",

    "config": {
        "cafile": "/Tangix_Work/my_cacert.pem"
    },
    "repositories": [
            {
                "type": "composer",
                "url" : "https://packages.morby.tangix.net/"
            }
    ],
    "require": {
        "php": ">=7.2",
        "codeigniter4/framework": "^4@beta",
        "tangix/vtxcommon": "dev-master"
    },
    "require-dev": {
        "mikey179/vfsstream": "1.6.*",
        "phpunit/phpunit": "^7.0"
    },
    "scripts": {
        "post-update-cmd": [
            "@composer dump-autoload"
        ]
    },
    "support": {
        "forum": "http://forum.codeigniter.com/",
        "source": "https://github.com/codeigniter4/CodeIgniter4",
        "slack": "https://codeigniterchat.slack.com"
    }
}
Reply

#12
(09-03-2019, 11:19 AM)tgix Wrote: Anyone more knowledgeable in composer that I am may point me in the right direction how to update a beta4 project to rc. Tried changing the require to 4@rc but no go.

There is no RC1 on packagist yet.
Reply

#13
(09-03-2019, 11:26 AM)michalsn Wrote: There is no RC1 on packagist yet.

OK. Will check later.

(09-03-2019, 11:28 AM)tgix Wrote:
(09-03-2019, 11:26 AM)michalsn Wrote: There is no RC1 on packagist yet.

OK. Will check later.

Seems like "later" is "now". Got the new version :-)
Reply

#14
(09-03-2019, 08:09 AM)jlp Wrote: CodeIgniter-4.0.0-rc.4 launches today 

Ooops! rc.4  Tongue
Test your translation files with Translation Tester
Reply

#15
(09-03-2019, 05:08 PM)includebeer Wrote:
(09-03-2019, 08:09 AM)jlp Wrote: CodeIgniter-4.0.0-rc.4 launches today 

Ooops! rc.4  Tongue

oops indeed! fixed it Angel
Reply

#16
Nice work CodeIgniter Development Team...
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply

#17
(09-03-2019, 11:22 AM)ciadmin Wrote:
(09-03-2019, 09:29 AM)byc0d3 Wrote: Can this version be used in production?

Officially, no.
Unofficially, many are already.

Here's a Power User, Johan van der Merwe, who wrote in 2016(!!), "CodeIgniter 4 PRE-ALPHA - A Complete New Ballgame!", that he was already using it to build REST-based applications!

Thanks CI4 Dev Team!

(Using CodeIgniter since 1.x)
Reply

#18
Thumbs Up 
I have used CI4 for my practice. I think it's gonna be good and better than CI3. Codeigniter 4 is Look like a new sense of Codeigniter. Good Job Codeigniter Team.....
Reply

#19
Greats!! When you do think that CI4 could be use in production?
Thanks again. Good job!
No SEO spam, per forum policy
Reply

#20
Bravo!
Thank you!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2019 MyBB Group.