• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CodeIgniter 4.0 Release framework - Kint Error

#11
CI 4 needs more testing before it goes to user level. because machine, version may differ from user to user
Reply

#12
(02-24-2020, 11:47 AM)dave friend Wrote: What fixed it for me (v4.0.0) was to run composer update

I tried that, but the bug seems to still be in 4.0.1. Are you using the development environment in your .env file or production? I think this would only affect people using development set as their environment.
Reply

#13
@dave friend and others...I'm thinking that this is at least partly a PHP issue.

I was on PHP Version 7.2.24-0ubuntu0.18.04.3 and both CI 4.0.0 and 4.0.1 threw a "Trying to get property 'maxDepth' of non-object" error.

However, when I upgraded to PHP 7.4.3, everything worked great. So I'm pretty sure that I either had something misconfigured in my 7.2 modules OR there's an obscure issue with Kint 3.3 and PHP 7.2
Reply

#14
(02-24-2020, 11:50 AM)marqone Wrote: I tried that, but the bug seems to still be in 4.0.1. Are you using the development environment in your .env file or production? I think this would only affect people using development set as their environment.

Yes, it is a development environment. Kint is a development tool and has no bearing on a production environment. In fact, it probably shouldn't be deployed to a production environment.

I am working off a fork of the repository so that I can stay current with the bleeding edge. When I fetched the latest development branch (yesterday but before the 4.0.0 release) I started getting messages about the kint file not being found. As I said before, "composer update" installed all the dev requirements and I was good to go.
Reply

#15
(02-24-2020, 11:58 AM)jameslittle Wrote: @dave friend and others...I'm thinking that this is at least partly a PHP issue.

I was on PHP Version 7.2.24-0ubuntu0.18.04.3 and both CI 4.0.0 and 4.0.1 threw a "Trying to get property 'maxDepth' of non-object" error.

However, when I upgraded to PHP 7.4.3, everything worked great. So I'm pretty sure that I either had something misconfigured in my 7.2 modules OR there's an obscure issue with Kint 3.3 and PHP 7.2


In the release of CodeIgniter, inside the Config folder, the file Kint.php has been added

Make sure you've added this file to your project's configuration folder too
Codeigniter 4 - Docker Image [github] [docker hub]
Reply

#16
(02-24-2020, 02:30 PM)atsanna Wrote:
(02-24-2020, 11:58 AM)jameslittle Wrote: @dave friend and others...I'm thinking that this is at least partly a PHP issue.

I was on PHP Version 7.2.24-0ubuntu0.18.04.3 and both CI 4.0.0 and 4.0.1 threw a "Trying to get property 'maxDepth' of non-object" error.

However, when I upgraded to PHP 7.4.3, everything worked great. So I'm pretty sure that I either had something misconfigured in my 7.2 modules OR there's an obscure issue with Kint 3.3 and PHP 7.2


In the release of CodeIgniter, inside the Config folder, the file Kint.php has been added

Make sure you've added this file to your project's configuration folder too

This seems to be exactly the issue. Thanks for tracking this down!
Designer, developer and Diet Dr. Pepper addict. Messing up PHP since <?= $when['year';] ?>
Reply

#17
(02-24-2020, 04:02 PM)jameslittle Wrote:
(02-24-2020, 02:30 PM)atsanna Wrote:
(02-24-2020, 11:58 AM)jameslittle Wrote: @dave friend and others...I'm thinking that this is at least partly a PHP issue.

I was on PHP Version 7.2.24-0ubuntu0.18.04.3 and both CI 4.0.0 and 4.0.1 threw a "Trying to get property 'maxDepth' of non-object" error.

However, when I upgraded to PHP 7.4.3, everything worked great. So I'm pretty sure that I either had something misconfigured in my 7.2 modules OR there's an obscure issue with Kint 3.3 and PHP 7.2


In the release of CodeIgniter, inside the Config folder, the file Kint.php has been added

Make sure you've added this file to your project's configuration folder too

This seems to be exactly the issue. Thanks for tracking this down!

Glad to have helped you!
Codeigniter 4 - Docker Image [github] [docker hub]
Reply

#18
The problem is that when updating via composer, the Kint.php file is not added to the Config directory.

For me the problem was solved by creating the Kint.php file and adding the code for that same file extracted from Git.


https://github.com/codeigniter4/CodeIgni...g/Kint.php
Reply

#19
I've had this problem too. People have outlined the fix, but to add, you need to copy the Kint.php file into your app. So from the root folder of your project type:

Code:
cp vendor/codeigniter4/framework/app/Config/Kint.php app/Config


I then set permissions on the new file for good measure:

Code:
sudo chmod 775 app/Config/Kint.php
Reply

#20
Thumbs Up 
(02-24-2020, 02:30 PM)atsanna Wrote:
(02-24-2020, 11:58 AM)jameslittle Wrote: @dave friend and others...I'm thinking that this is at least partly a PHP issue.

I was on PHP Version 7.2.24-0ubuntu0.18.04.3 and both CI 4.0.0 and 4.0.1 threw a "Trying to get property 'maxDepth' of non-object" error.

However, when I upgraded to PHP 7.4.3, everything worked great. So I'm pretty sure that I either had something misconfigured in my 7.2 modules OR there's an obscure issue with Kint 3.3 and PHP 7.2


Quote:In the release of CodeIgniter, inside the Config folder, the file Kint.php has been added

Make sure you've added this file to your project's configuration folder too


This fixed it for my install as well. Just copied the file from the vendor/codeigniter4/framework/app/config/Kint.php into my /app/config folder. Thank you atsanna!
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.