• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] upgrade 4.0.2 to 4.0.3 error

#1
Hi,

currently my CI version is 4.0.2.

since 4.0.3 already released, i go to my console at project root then run this cmd : composer update

then i noticed the composer remove the codeigniter 4.0.2 in the vendor/ci4/framework folder then created a new folder
codeigniter-standard.

still, my CI remain 4.0.2.

Or i missed some step?

my understanding is whenever new version coming out, i should get a new version in 'vendor/ci4/framework' (just like first setup in documentation)
then i just copy those files into my project root folder.

*UPDATE:
Looks like it happened because i copied whole composer.json file from the vendor/ci4/framework into my project root. as a result, the setting for "codeigniter4/framework": "^4"codeigniter was missing. When i put it back and use composer update, the folder for ci4/framework is coming back with version 4.0.3
Reply

#2
Nothing like that on my side o just hit composer update and everything went just fine.
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2021 MyBB Group.