Welcome Guest, Not a member yet? Register   Sign In
initial response time is too slow
#11

I don't know, there is something weird with your server or configuration. It's almost impossible to know what is going on just like that because that's not normal behavior. What does the apache's log say? If you have an error 500 it must crash somewhere, and there must be an error message with a filename and line number?
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
Reply
#12

(12-30-2020, 07:14 AM)includebeer Wrote: I don't know, there is something weird with your server or configuration. It's almost impossible to know what is going on just like that because that's not normal behavior. What does the apache's log say? If you have an error 500 it must crash somewhere, and there must be an error message with a filename and line number?

This is the error from cpanel error logs
SoftException in Application.cpp:690: Could not execute script "/home1/public_html/public/index.php"
and there is no issues with permission as it works fine for single request only if multiple requests are made at the same time this issue occurs
And this is only happening with CI projects tried others even with 5000 requests at a time my server is handling it without a single error
Reply
#13

(12-30-2020, 08:55 AM)refay Wrote: the first request to the server takes atleast 3-5 seconds and subsequent requests if made within 5-10 seconds takes 400-700ms

it works fine for single request only if multiple requests are made at the same time this issue occurs

You first said that the first request took 3-5 seconds and the other requests took 400-700ms, but now you say the problem occurs only when you make multiple requests at the same time...? 

This may be related to the sessions. If you make 5000 requests from postman, they will all use the same session and will block each others because it all come from the same client. Check your session parameters in CI and in php.ini. It may be what is causing these issues.
CodeIgniter 4 tutorials (EN/FR) - https://includebeer.com
Reply
#14

(12-30-2020, 09:34 AM)includebeer Wrote:
(12-30-2020, 08:55 AM)refay Wrote: the first request to the server takes atleast 3-5 seconds and subsequent requests if made within 5-10 seconds takes 400-700ms

it works fine for single request only if multiple requests are made at the same time this issue occurs

You first said that the first request took 3-5 seconds and the other requests took 400-700ms, but now you say the problem occurs only when you make multiple requests at the same time...? 

This may be related to the sessions. If you make 5000 requests from postman, they will all use the same session and will block each others because it all come from the same client. Check your session parameters in CI and in php.ini. It may be what is causing these issues.

the delay issue still exists even for 1 request but i can live with that
And i am not using sessions
i think issue is with the php in cpanel. Before i was testing with a html file outside CI directory. When i created a php file just to echo hardcoded string the issue still exist its not even passing 100 request at a time.
So its not a CI issue
Reply




Theme © iAndrew 2016 - Forum software by © MyBB