Page not loading properly, need to hit refresh to see current page.

#1
[eluser]skrobma[/eluser]
I believe this has to do with a common controller I created. Whenever it's called the page just loads with the same data. But when I hit the refresh button the page changes properly.

This happens with the menu items (categories) and login which are both in the common controller.

You need to login for the categories to populate. (if you have problems logging in just go back to the site defined and click refresh.
Site: http://www.mypodstudios.com/asco/
login: asco/asco123

The asco controller builds the page. Common performs login/logout/category change.


Below is the category code from the common controller.
Code:
function cat()
    {
        $redir = $this->session->userdata('pod_path'); //asco
        // UNSET Video so next refresh has image not video
                $this->session->unset_userdata('vid_id');
        $this->session->set_userdata('catid',$this->uri->segment(3));
        redirect($redir);    
    }

Thanks -Mark

#2
[eluser]krwl[/eluser]
how about add 'refresh' flag in redirect function?
Code:
redirect($redir, 'refresh');

#3
[eluser]skrobma[/eluser]
Thanks, I tried that. At home it works fine, at work it doesn't. I think it's because the firewall may cache the page.

I always redirect to the original page.

Start: www.mypodstudios.com/asco/
Link executed on page: www.mypodstudios.com/common/cat/1 (set some session variables)
Which redirects back to www.mypodstudios.com/asco/ (display the page based on the new session variable)

Any problem with doing this, most of my site is built this way. That is, it always redirects back to www.mypodstudios.com/asco/


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2020 MyBB Group.