• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
cURL Issue in CodeIgniter

#1
hi So first, let me admit that the problem is definitely somewhere in the codeigniter framework, or how I'm processing the cURL post from the test feed.

Here's the problem. I have the sample feed php file sitting in the root directory and have is posting to a controller via cURL. I've tested the functionality out of the framework and it works fine, but for some reason when I post into the CI controller, something breaks.

The first bit of the pure urlencoded() cURL post is
%15F%0A%05%1EW%E4%ED%F8%97h%B7%C7%C4%E0%0A%27U-%D0d%E1%EE%E7%F7%D1%2F%BF%24%E0%C8yD%C2%C7p% [<<MORE>>}
Again, this is the byproduct of the test_xml_datafeed.0.7.php with my site's key.

However, when I check the post data from within my controller (before decoding or decrypting) this is what I get:
F%0A%1EW%E4%ED%F8%97h%B7%C7%C4%E0%0A%27U-%D0d%E1%EE%E7%F7%D1%2F%BF%24%E0%C8yD%C2%C7p% [<<MORE>>]



Also, global XSS filtering is off.
$config['global_xss_filtering'] = FALSE;


Any ideas on what could be causing the alteration?

Since it'll work out of the framework, I can build something to process the feed, but it would make life easier if I could get this to work within the framework.

Any assistance would be greatly appreciated  Big Grin
Reply

#2
Maybe this article will point you in the right direction.


CodeIgniter : PHP Curl library with SSL Example
What did you Try? What did you Get? What did you Expect?

Joined CodeIgniter Community 2009.  ( Skype: insitfx )
Reply


Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Users browsing this thread:
1 Guest(s)


  Theme © 2014 iAndrew  
Powered By MyBB, © 2002-2018 MyBB Group.