Welcome Guest, Not a member yet? Register   Sign In
Kint Class Not Found
#1

(This post was last modified: 02-26-2020, 11:42 PM by mjamilasfihani.)

Hi, any suggestion for this error? I set the environment to production

While in localhost everything is fine, but when it on air the log show :

Code:
CRITICAL - 2020-02-27 13:34:01 --> Class 'Kint\Kint' not found

Thanks
A man behind CI 4 Assets Generator
Reply
#2

(02-26-2020, 11:41 PM)mjamilasfihani Wrote: Hi, any suggestion for this error? I set the environment to production

While in localhost everything is fine, but when it on air the log show :

Code:
CRITICAL - 2020-02-27 13:34:01 --> Class 'Kint\Kint' not found

Thanks

If you are on linux platform,  Go to System/ThirdParty/Kint, and rename the kint.php to Kint.php
This solved the issue in my case.
Reply
#3

Rename system/ThirdParty/Kint/kint.php to system/ThirdParty/Kint/Kint.php
Reply
#4

(This post was last modified: 02-27-2020, 04:38 AM by Stormbringer.)

I have the same problem only on production.
After upgrade from RC4 to 4.0.2
Reply
#5

I have the same problem in the web server (but not in local) with version 4.0.2, but not with version 4.0.0-rc4
Reply
#6

Yes, I've just had the same error on remote hosting server with version 4.0.2. As Navindex told advised, renamed kint -> Kint and error has disappeared.
Reply
#7

(02-27-2020, 09:09 AM)serge78 Wrote: Yes, I've just had the same error on remote hosting server with version 4.0.2. As Navindex told advised, renamed kint -> Kint and error has disappeared.
Thanks and thnks to Navindex, I didn't notice the lower to upper case difference!!!
Reply
#8

The version of Kint changed from 2.x branch to the 3.x branch. While renaming Kint class will get rid of that error, there still might be other errors you get in development due to the version differences. However, Kint never runs in production so if you've already got a site deployed it shouldn't cause any issues. Always better to be safe, though, and copy the files from the 4.0.2 repo (ThirdParty/Kint) over to your project.
Reply
#9
Thumbs Up 

Solved the problem - can this be corrected in the next release?

On localhost (windows-Wamp) capitals on file is less important. Production site is Linux with stricter filerules!
Reply
#10

(This post was last modified: 03-21-2020, 02:13 PM by mjamilasfihani.)

(03-20-2020, 02:13 AM)Bart Goossens Wrote: Solved the problem - can this be corrected in the next release?

On localhost (windows-Wamp) capitals on file is less important. Production site is Linux with stricter filerules!

Yeah I agree with you

(03-03-2020, 07:58 AM)kilishan Wrote: The version of Kint changed from 2.x branch to the 3.x branch. While renaming Kint class will get rid of that error, there still might be other errors you get in development due to the version differences. However, Kint never runs in production so if you've already got a site deployed it shouldn't cause any issues. Always better to be safe, though, and copy the files from the 4.0.2 repo (ThirdParty/Kint) over to your project.

If I remove toolbar in filter, it will not load Kint class right? If yes it will not have any issues like what you mean
A man behind CI 4 Assets Generator
Reply




Theme © iAndrew 2016 - Forum software by © MyBB